Tue, 18 May 2004

freevo audio playing

Well, I've been working on trying to fix this one simple little issue in freevo that has slowly been eating at me. I was using xmms for music as it seemed to work best with the alsa drivers and SPDIF output (mplayer was doing some odd things with this setup). But it would not skip tracks on it's own unless you interacted with it after playing a track (for instance skipping 10 second in the track). So if you just hit play on a track, it would play the track and then just sit there at the end of it and not skip to the next. So anyways, after spending about 2 hours trying various things and hacking around in freevo's fxmms module I gave up and decided to try mplayer again. After doing a little research I was able to get mplayer working the way I wanted by forcing it to resample everything at 48kHz. mplayer -af resample=48000:0:0 This fixed all the issues I was having with mplayer playing certain mp3's faster than it should. And so, that fixes all the issues I was having with freevo and it's working perfectly. I'm going to try to put together a webpage with some details about the specifics of the setup with the Via Epia M10000 system at somepoint I hope.

posted at: 19:10 | path: /freevo | permanent link to this entry


2019-Sep
2019-Jul
2019-Jun
2019-May
2018-Dec
2018-Jan
2017-Aug
2017-Jun
2017-May
2016-Nov
2015-Dec
2015-Nov
2015-Oct
2015-Jul
2015-Jun
2014-Dec
2012-Oct
2012-Sep
2012-Jun
2012-Feb
2012-Jan
2011-Dec
2011-Sep
2011-Aug
2011-May
2011-Feb
2010-Jun
2010-Apr
2010-Jan
2009-Sep
2009-Jul
2009-May
2009-Jan
2008-Oct
2008-Sep
2008-Jun
2008-May
2008-Jan
2007-Nov
2007-Oct
2007-Aug
2007-Jun
2007-May
2007-Mar
2007-Feb
2007-Jan
2006-Nov
2006-Oct
2006-Sep
2006-Aug
2006-Jun
2006-Apr
2006-Jan
2005-Dec
2005-Nov
2005-Oct
2005-Sep
2005-Aug
2005-Jul
2005-Jun
2005-May
2005-Apr
2005-Mar
2005-Feb
2005-Jan
2004-Dec
2004-Nov
2004-Oct
2004-Sep
2004-Aug
2004-Jul
2004-Jun
2004-May

Powered by PyBlosxom | RSS 2.0